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Open solutions for SDG monitoring: 
Introduction to Quantum GIS 
 

This exercise is based on a series of exercises by Dr. Vince Láng1, developed for the course „GIS 

Applications in Natural Resource Management”. 

Developed by Dr. Zoltán Vekerdy 1,2, Dr. István Waltner 1 and János Grósz1  

1 Faculty of Agricultural and Environmental Sciences, Szent István University, Gödöllő, Hungary  

2 Faculty of Geoinformation Science and Earth Observation (ITC), University of Twente, Enschede, the 

Netherlands  

 

Objectives, materials 
Objective of the exercise: To give an impression about how QGIS can be used and to make the first steps 

in using the software in environmental applications related to the Sustainable Development Goals.  

Tasks: Basic operations in QGIS, including: Display and edit vector and raster maps, link to web services 

and compose a map for printing. 

Required time: 3-8 hours, depending on the GIS-QGIS experience of the course participant. 

We designed the exercise as a stand-alone teaching material; the execution can be started during the 

face-to-face part of the Summer School, but can be continued afterwards, if needed. 

Data set: GIS data about the Lake Uromiyeh Basin, Iran. 

The data base is attached in a separate folder IntroQGIS_data. 

File name Explanation 
…\Maps\Islands.shp, .dbf, .prj, .qpj, .shx Islands in Lake Uromiyeh 
…\Maps\lake_20160623.shp, .dbf, .prj, .qpj, .shx Lake Uromiyeh 23.06.2016 
…\Maps\Lakes.shp, .dbf, .prj, .qpj, .shx Lakes and reservoirs 
…\Maps\Pop_larger.shp, .dbf, .prj, .qpj, .shx Larger populated places 
…\Maps\Pop_small.shp, .dbf, .prj, .qpj, .shx Small populated places 
…\Maps\Road_dirt.shp, .dbf, .prj, .qpj, .shx Dirt roads 
…\Maps\Road_highway.shp, .dbf, .prj, .qpj, .shx Highways 
…\Maps\Road_paved.shp, .dbf, .prj, .qpj, .shx Paved roads 
…\Maps\Streams.shp, .dbf, .prj, .qpj, .shx Rivers and streams 
…\Maps\subbasin.shp, .shx, .dbf Watershed and sub-basins map 
…\Landsat\*.* Landsat 8 image layers of the area 

  

Remarks: 



 P a g e  | 2  

 

 

I n - S e r v i c e  I C T  T r a i n i n g  f o r  E n v i r o n m e n t a l  P r o f e s s i o n a l s  ( I S E P E I )  
Geospatial Technologies and Remote Sensing for Monitoring SDGs 

4-8 July 2016, Central European University, Budapest, Hungary 
http://isepei.org 

 

 All maps were digitized from the 1:500,000 topographic maps 

  

Conventions in this document: The following typesetting conventions are used: 

 Tasks are shown with this arrow. These are the steps you have to carry out during the exercise. 

File names and other computer input is shown with this font. 

Background information about the case study: Lake Uromiyeh case study at 

http://isepei.org/case-studies/twente-itc/environmental-management-plan-lake-uromiyeh-ecosystem-

iran 

 

  

http://isepei.org/case-studies/twente-itc/environmental-management-plan-lake-uromiyeh-ecosystem-iran
http://isepei.org/case-studies/twente-itc/environmental-management-plan-lake-uromiyeh-ecosystem-iran
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Introduction 
In this exercise, we use the Geographic Information Systems (GIS), called QGIS (Quantum GIS). This is a 

freeware available for Linux, Mac OS, Windows and Android. This makes this program a powerful tool to 

be used not only in the office but to bring it to the field on a tablet or a smartphone. 

Many NGOs and other organizations are moving to open access programs, and many are using QGIS as 

their main GIS software. QGIS is not only building on its own options and available tools, but it can use 

great tools of other GIS and related software, like R, SAGA or GRASS, among others, which are tools for 

statistics of for handling raster data. Additionally, many plugins written by users are available, thanks to 

being open source. The scripting language is Python, which is an easy to learn coding language, which can 

be used for building customized workflows or to speed up big data handling. 

Loadable and savable data formats include almost every common file types. This includes shape files, 

different raster formats, AutoCad files etc., which can then be use in other software. 

The Quantum GIS software 
 To start from the very basics go to the QGIS website (http://www.qgis.org/en/site/). 

NOTE: QGIS was started as Quantum GIS, but most users used the short form QGIS. They have recently 

issued an official statement that from 2014 it is officially QGIS. 

You will find the download button, where you can find all the available downloadable versions. Besides 

the program itself many useful and interesting materials are available. Please use this as a source of 

information if you are stuck with something. 

Another good information source is the Geographic Information System Stack Exchange website 

http://gis.stackexchange.com/. Many questions have been raised and answered here so it is also a good 

source. 

  

http://www.qgis.org/en/site/
http://gis.stackexchange.com/
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Overview of the QGIS interface  
We will explore the QGIS user interface so that you are familiar with the menus, toolbars, map canvas 
and layers list that form the basic structure of the interface.  

 

 
 
 
The elements identified in the figure above are:  
1. Layers list  
2. Toolbars  
3. Map canvas  
4. Status bar  
5. Layers manager  
Your interface may differ a bit. It can be changed according to User preferences:  
1. Right click somewhere on the menu (Area 2 or 5)  

2. A window will pop up with the available menu bars  

  

1. Loading and displaying vector data from shapefiles  
The Shapefile is a specific file format that allows you to store GIS data in an associated group of files. 
Each layer consists of several files with the same name, but different file types. Shapefiles are easy to 
send back and forth, and most GIS software can read them.  
Refer back to the introductory exercise in the previous section for instructions on how to add vector 
layers.  

 Look for the Add Vector Layer button in Layer menu or Use the Add vector layer on the left side  

1 3 

4 

5 

2 
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 Click on it to open the following dialog:  

 

 

 Click on the Browse button and navigate to the file: …\Maps\Lakes.shp 

 With this file selected, click Open. You will see the original dialog box, but with the file path filled 

in. Click Open here as well. The data you specified will now be loaded.  
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The layer now displayed shows Lake Uromiyeh, along with some smaller reservoirs. To get a feel of the 

data, try zooming in and out a little: 

 Use the scroll wheel of your mouse to zoom in and out. Notice that the scale in the status bar is 

changing. 

Let us now load some other layers to our display. 

 Load the following shapefiles: Islands.shp, Pop_larger.shp, Pop_small.shp, Road_dirt.shp, 

Road_highway.shp, Road_paved.shp, Streams.shp 

The layers are displayed on top of one another, in the same order you have added them to the display. 

This means that if you have followed the order above, some roads now run across the dots representing 

populated areas. Change the order of layers so that we have the Pop_small and Pop_larger layers on top.  

 In the Layers list area, move your mouse over the name of the Pop_small layer and by holding 

down the left mouse button drag it to the top of the list. Repeat the same with the Pop_larger 

layer.   

Using the random palette automatically assigned when loading the layers, your current map  
is probably not easy to read. It could have colours different than that of the present map. It would be 
preferable to assign your own choice of colors and symbols.  
 

Changing colors  
To change a layer’s symbology, open its Layer Properties. Let’s begin by changing the color of the 
Streams layer.  

 Right-click on the Streams in the Layers list.  
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 Select the menu item Properties in the menu that appears.  

 

 Note: By default, you can also access a layer’s properties by double-clicking on the layer in the 

Layers list.  

 In the Properties window:  
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  Select the Style tab at the extreme left 

 

 Click on the displayed color right from the Color sign.  

 

 The Select color menu will appear and you can choose the desired one. Since the layer is about 

streams let’s choose something blue. 
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Now would probably be a good time to save your progress. QGIS can save all the layers that you have 

opened in a project file, so you can come back to them as they were and continue from there. 

 Click on the Project menu. 

 

 

 From the menu, select “Save”, and browse for your working directory. Select a name for your 

project (suggestion: Uromiyeh). 
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Next time you need to load the project, you can load just double click the project file from your file 

manager to start QGIS where you left off, or you can load a project from the “Project” menu from QGIS. 

 

Defining a Coordinate Reference System 
Sometimes, when you access data from different sources, they can use different coordinate systems. 

Upon opening these layers QGIS is generally able to transform them to the view, so you see no error 

messages or problems. However, if for some reason your data is missing spatial reference, you will have 

to define it. 

 Load the subbasin.shp layer. 

Notice the yellow alert message in the top of the display area. 

 

Note: under some settings the Coordinate Reference System Selector window may pop up automatically. 

If you look at the files, you can see that the subbasin layer is missing a .prj file. Without any information, 

QGIS is trying to use a default projection system (WGS84), but it is unable to add the layer to the current 

view. Let’s sort this out. 

 Right click on the subbasin layer. 

 

 

 Left click Set Layer CRS. 
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 In the Coordinate Reference System Selector window, left-click to the box next to Filter, and type 

“UTM zone 38N”. From the filtered list, select “WGS84 / UTM zone 38N”. 

 

 Click “OK”.  

Move the subbasin layer to the background so you can see the other layers.  

Your display should resemble something like this: 
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Now would probably be a good time to save your progress.  
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2. Adding a raster layer  
Raster layers are different from vector layers. They are defined with cells. On 1 layer cells are normally 
the same size. Each cell has value(s) assigned to them and these values can be viewed, analyzed etc. 
 
Let’s add a raster layer to our map.   
Now we will just add 1 raster layer (a coarse resolution satellite image) to our map to make it „nicer”.  

 From the Layer menu click on Add Raster Layer (or on the left menu bar). Load the file 
LC81690342016175LGN00_B2.tif 

 

If your view of the layer is obstructed by other layers, you can set the layer order as learned before, 

or you can switch on and off layers by (un)ticking the little boxes next to them in the Layers list. 

 Arrange the layers so that you have a clear view of the raster layer. 

The layer we have just loaded has the data of Band 2 for a Landsat 8 satellite image. Band 2 refers to 

the spectral range for the color blue.  

Merging image layers (optional) 
Most satellite images data is distributed as separate layers for each spectral band. This means that we can 

display them individually (see Exercise 2). However, while for certain purposes (such as processing and 

handling data) such arrangement is beneficial, but we generally prefer to look at images in color, or false 

color. This helps with the visual interpretation of the images, even if some of the bands are actually not 

in the visible range (false color). In order to have all bands in one file, we will have to merge the different 

raster layers together. 

Note: this part of the exercise is optional, since the processing can take a significant amount of time 

depending on the computer. 

 From the menu select Raster -> Miscallenous -> Merge 
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 In the Merge window, browse for input files. You will have to select all 11 layers for the Landsat 

image from LC81690342016175LGN00_B1.tif to  LC81690342016175LGN00_B11.tif. 

 In the Merge window, browse for the output directory and name your output file “Landsat_2016”. 

The format will be GeoTiff. 

 Select “Layer stack” 



 P a g e  | 15  

 

 

I n - S e r v i c e  I C T  T r a i n i n g  f o r  E n v i r o n m e n t a l  P r o f e s s i o n a l s  ( I S E P E I )  
Geospatial Technologies and Remote Sensing for Monitoring SDGs 

4-8 July 2016, Central European University, Budapest, Hungary 
http://isepei.org 

 

 

 Click OK to run the merging process. It may take a long time. Once it is done you will see two 

windows popping up, one for finishing the process, and one for the progress (you should see it 

through the merge, but your computer may not be able to display it. Click OK for both. 

 Click “Close” to get rid of the Merge window. 

Now you should have a new layer called “Landsat_2016” and it should  

 

 

 

 

Selecting different bands for display 
 

For the purpose of this exercise, let’s present a true color image of Lake Uromiyeh based on a Landsat 8 

satellite image. For Landsat 8, Band 2 is for the Blue, Band 3 is for the Green and Band 4 is for the Red 

color range. 

 Load the prepared Landsat image (Landsat_2016.tif or use the pre-merged Landsat_2016_v2.tif) 
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 Open the Properties window for the layer 

 For Render type, choose “Multiband color”. Select the three bands:  Red = 4, Green = 3, Blue = 2. 

Click OK. 

 

The resulting image should look like this: 
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4. Case study: changes in lake area 
 

As displayed in the case study, Lake Uromiyeh’s area is changing. Let’s asses the change to see how much 

of the lake has dried out.  

We already have the Lakes layer that includes Lake Uromiyeh along with some smaller reservoirs. We will 

now create a new layer that only contains the lake itself. Also, we will change the Coordinate reference 

system, so that we can calculate lake area in square kilometers. 

 In the Layers list, select the Lakes layer 

 From the toolbars click on  “Select Features by area or single click” 

 

 

 Click within the area of Lake Uromiyeh. It should now be displayed as bright yellow. 

 

 In the Layers list, right-click on the Lakes layer and select “Save as” 
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 In the Save vector layer as window, choose a name (“Lake_old” for example) and folder for the 

new file. Also, in the CRS section, select WGS 84/UTM zone 38N (see above). Don’t forget to tick 

the Save only selected features box. 

We now have a map of the lake with meters as map units. Let’s load a recent extent of the map. 

 Load the vector layer from Lake_2016.shp 

Now you should have both layers. After arranging the layers it should be clear that the 2016 extent is 

much smaller than the older one. Now we will create a new layer showing only the difference (i.e. the 

area that is now dry). 

 Select Vector -> Geoprocessing tools -> Difference 
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 In the Difference window, select Lake_old as input layer, while Lake_2016 as your difference layer. 

Select the location and name (Lakebed_dry) of the output file. 

 

The output layer will now contain the area that has dried out from the old lakebed. 
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Now we need to calculate the actual area of the poligons. First, let’s do it for the old lakebed. 

 Select the Lake_old layer. Now open the Field Calculator as shown below: 

 

 

 In the Field calculator window, name our new field “Area”. From the Functions list, select 

Geometry -> $area by double clicking it. 

 Since it is a large lake, and the map units are in meters, we should expect large numbers, so let”s 

convert to square kilometers by adding “/1000000” to the expression on the left. 



 P a g e  | 21  

 

 

I n - S e r v i c e  I C T  T r a i n i n g  f o r  E n v i r o n m e n t a l  P r o f e s s i o n a l s  ( I S E P E I )  
Geospatial Technologies and Remote Sensing for Monitoring SDGs 

4-8 July 2016, Central European University, Budapest, Hungary 
http://isepei.org 

 

 

 Alternatively, you could just type the whole thing: “$area  / 1000000” 

 Now click OK. 

Note: the actions above will toggle editing. This can be undone by clicking the “Toggle editing” 

button. 

Now we should have a new column in the layer’s attribute table. 

 Right click on the layer, select Open Attribute Table. 

This opens up the attribute table, where you can see that the area of the lake was 4619 km2. 
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 Repeat the same process for the 2016 area. 

 

If you have done everything correctly, your result should be 2452 km2. 

Based on this you can calculate that the Lake has lost (4619-2452=) 2167 km2 or (2452/4619*100=) 

53 % of its area. 
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5. Creating a print-ready map 
 

In this exercise, we will create a very simple print ready map that shows the difference in surface extent 

for the lake. 

 Remove all layers from the map, except Lake_old and Lake_2016. You can remove a layer by right-

clickin on it and selecting “Remove”. Arrange the remaining two layers so that we can see the 

outline of both (2016 should be on top). 

Let us now add some background. 

 From the main menu bar select Web -> OpenLayers plugin -> OpenStreetMap -> OpenStreetMap 

 

 

Now you can see your layers displayed on top of the OpenStreetMap layer. 
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Now let’s begin to create a map layout. 

 Open a new print composer. You will be requested to add a title to your composer. Let’s call it 

Uromiyeh 

 

 

The print composer is essentially a blank page, where you can add your map displays and additional 

features.  

 

 

 Add a new map by selecting the “Add new map” button from the toolbar on the left. 
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 Create a map area on you blank page by clicking and dragging while holding down your left mouse 

button. 

You now should see the same layers in your composer as in the display area of QGIS. 
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 Explore your options within the Composer. Use your creativity to create your own custom map 

from the data you have. You map should have at least all of the following:  

o a map 

o a scale bar 

o a legend 

o a title. 

 Once you are done and your map is perfect, you can either print it, or export it as an image or a 

pdf. 

 

 

 


